Back to overview
Downtime
roblox.com/communities/15833094/Polar-Tracks#!/about and roblox.com/games/12894431123/Polar-Tracks-Railway-BETA are down
Aug 16 at 10:13am HDT
Affected services
roblox.com/communities/15833094/Polar-Tracks#!/about
roblox.com/games/12894431123/Polar-Tracks-Railway-BETA
Resolved
Aug 16 at 10:22am HDT
roblox.com/games/12894431123/Polar-Tracks-Railway-BETA recovered.
Affected services
Updated
Aug 16 at 10:19am HDT
roblox.com/communities/15833094/Polar-Tracks#!/about recovered.
Affected services
Created
Aug 16 at 10:13am HDT
roblox.com/communities/15833094/Polar-Tracks#!/about and roblox.com/games/12894431123/Polar-Tracks-Railway-BETA went down.
Affected services